Exchange 2019 support msXfax

Microsoft default installation of Exchange Server 2019 does not  support TLS 1.0 and 1.1   TLS 1.2 and above is supported.
 

 

Customers who plan to install \ upgrade to Exchange 2019 and who have an existing fax server running on Windows 2012 R2 will need a patch from BNS to support Exchange 2019.

Customers who plan to install a new fax server will be required to install on Windows Server 2016 or better using the latest software release of msXfax. 
  

As Used By

BNS Group Canberra

PO BOX 671 Woden
ACT 2606 Australia
Tel +61 (2) 62312704
Fax +61 (2) 61986500

BNS Group Sydney

Tel +61 (2) 99720113